SoCalEcotecs

A group of car enthusiast that support the Ecotec motor and the Delta platform

Welcome to the SoCalEcotecs forum. When you first join the site be sure to go to the welcome center and create an Intro thread that includes your Name, what city you live in and what car you drive.

    New to this site but not the car

    avatar
    chevy454400205

    Posts : 4
    Reputation : 0
    Join date : 2011-11-30

    New to this site but not the car Empty New to this site but not the car

    Post by chevy454400205 on Wed Nov 30, 2011 2:36 am

    My name is Matt. I live in La Habra and have meet a few people. I have an 06 ss/sc. Destroyed the motor yet again and am working on putting it back together again
    THEJoey.
    THEJoey.

    Posts : 1173
    Reputation : 12
    Join date : 2010-07-09
    Age : 33
    Location : Riverside

    New to this site but not the car Empty Re: New to this site but not the car

    Post by THEJoey. on Wed Nov 30, 2011 2:53 am

    welcome to the site Matt

    if u have any questions any one member should be of help


    _________________
    New to this site but not the car Dsm_sig_2013
    Mofofernando
    Mofofernando
    Admin

    Posts : 1733
    Reputation : 2
    Join date : 2010-07-08
    Age : 34
    Location : PERRIS

    New to this site but not the car Empty Re: New to this site but not the car

    Post by Mofofernando on Wed Nov 30, 2011 4:28 am

    Welcome and how'd you destroy it?


    _________________
    New to this site but not the car Aaron100_sig1
    MikethemodlistKoldus
    MikethemodlistKoldus

    Posts : 2320
    Reputation : 7
    Join date : 2010-07-22
    Age : 36
    Location : HB

    New to this site but not the car Empty Re: New to this site but not the car

    Post by MikethemodlistKoldus on Wed Nov 30, 2011 11:27 am

    welcome and yea howd you destroy it again? self tuning lol


    _________________
    New to this site but not the car 383905_2859495123326_1138097546_33242731_1473110793_n
    avatar
    chevy454400205

    Posts : 4
    Reputation : 0
    Join date : 2011-11-30

    New to this site but not the car Empty Re: New to this site but not the car

    Post by chevy454400205 on Wed Nov 30, 2011 7:51 pm

    Ever since I first melted a piston and rebuilt it it hasn't lasted long after redoing it each time. I think the problem this time is the head. I'm not sure if the damage is more extensive cause I haven't taken it apart yet, but I will be finding out soon
    avatar
    chevy454400205

    Posts : 4
    Reputation : 0
    Join date : 2011-11-30

    New to this site but not the car Empty Re: New to this site but not the car

    Post by chevy454400205 on Wed Nov 30, 2011 7:52 pm

    The tune had nothing to do with it
    Mofofernando
    Mofofernando
    Admin

    Posts : 1733
    Reputation : 2
    Join date : 2010-07-08
    Age : 34
    Location : PERRIS

    New to this site but not the car Empty Re: New to this site but not the car

    Post by Mofofernando on Wed Nov 30, 2011 8:20 pm

    Melted piston sounds tune related and maybe there was more initial damage than you thought that never got fixed.


    _________________
    New to this site but not the car Aaron100_sig1
    avatar
    chevy454400205

    Posts : 4
    Reputation : 0
    Join date : 2011-11-30

    New to this site but not the car Empty Re: New to this site but not the car

    Post by chevy454400205 on Thu Dec 01, 2011 12:16 am

    The piston was from heat and not enough cooling. After I fixed it had it tune properly.

    Sponsored content

    New to this site but not the car Empty Re: New to this site but not the car

    Post by Sponsored content


      Current date/time is Sun Apr 05, 2020 1:27 am